Command-line version

Usage:

  RadClk [/d] [/l|/s] bios.rom [GPU_clock RAM_clock] [newbios.rom]

Switches:

  /d dump chip initialization script
  /l load 'font8x8.fnt' and 'font8x16.fnt' font files
  /s save fonts to 'font8x8.fnt' and 'font8x16.fnt' files

How to:

  view bios info:
    RadClk.exe bios.bin

Warning! You are advised to view bios info first,
and only make any changes if the displayed information
is correct.

  set clocks to 268/266 Mhz:
    RadClk.exe bios.bin 268 266

  save bios fonts:
    RadClk.exe /s bios.bin

  load fonts:
    RadClk.exe /l bios.bin

  copy bios1.bin fonts to bios2.bin:
    RadClk.exe /s bios1.bin
    RadClk.exe /l bios2.bin

  fix checksums and save fixed bios to fixed.bin file:
    RadClk.exe bios.bin fixed.bin

  fix bios checksums:
    RadClk.exe bios.bin bios.bin

  dump chip initialization scripts:
    RadClk.exe /d bios.bin > script.txt


DOS version

RadClk supports all Win32 console functionality, plus:

specifying 'mem' as file name reads bios image from memory

/a enables all TV standards

/i reinitializes BIOS image

/r try to restore BIOS image from Shadow ROM


Where to get BIOS image

Where to get a BIOS image

The simplest way is to extract the BIOS from you own video card. You can do this with a flashing utility, for example:

flashrom -s 0 my_bios.rom

You can also use a BIOS image from a compatible video card from the Downloads section of radeon2.ru.

You may do that for changing PAL/NTSC TV standard, or for better overclocking. For example, flashing a retail Radeon 8500 BIOS to a OEM/LE card can give you 2-5 Mhz or even more memory overclocking potential.


BIOS Flashing

There are special flashing programs than can be downloaded from the Downloads section of the radeon2.ru website.

Before flashing, it is strongly recommended to:

  1. Save your old BIOS image.
  2. Check that you card works at the frequencies you are flashing without artifacts by first testing the frequencies with PowerStrip or another tweaker. Be sure to check carefully to make sure there are no artifacts in the High Detail Game2 and Game3 tests and the Vertex Shader and Dot3 tests in 3Dmark2001.
  3. If you use PowerStrip, be sure to disable its clock setting auto-load or even remove its ini-files, otherwise it will load you card settings as before flashing and you will not note any difference.
  4. Check your new BIOS image settings with this editor or the BiosInfo utility.
  5. Use pure DOS mode when flashing (without himem.sys, etc.). In other words, do a clean boot from a floppy if necessary. There should be no programs running in memory during the process of flashing the BIOS.
  6. If you are trying to flash a non-native BIOS (from another video card), check to see if it works with the RamBios utility.
  7. Always have a PCI or ISA video card available for use in recovering your system in case anything goes wring with the flashing process.

Recommended flashing procedure:

  1. Download the flashing utility.
  2. Unzip flashrom.exe and flashrom.rom to a clean DOS (or Windows) floppy. Also copy RadClk.exe if you want to view or modify bios directly from DOS, and rambios.exe if you want to test bios image before flashing. If you already have a bios image you want to flash, also copy it to the same floppy.
  3. Reboot your computer from this floppy.
  4. Execite:
    flashrom -s 0 old_bios.rom
    command.
  5. View bios info with:
    RadClk old_bios.rom
    command.
  6. If displayed information is correct, and it has "Core clocking" and "Memory clocking" lines, set the desired frequencies with:
    RadClk old_bios.rom 285 265 new_bios.rom
    command. In this example core clock is set to 285, and memory to 265. Or reboot to Windows and edit your bios with RadEdit.
  7. Flash your new bios with:
    flashrom -p 0 old_bios.rom r
    command. It will restart automatically.


TV Out

PAL is an european 50 Hz TV standard.

NTSC is an american 60 Hz TV standard.


Memory timings

SDR = Single Data Rate

DDR = Double Data Rate

Note: memory timings seems to have no effect on Radeon 8500


About

This software is granted AS-IS. Neither its author nor radeon2.ru takes any responsibility for any possible harm caused by the use of this software.

RadEdit is a BIOS image editor for the ATi Radeon series of cards. It allows you to change the core and memory frequency, TV standard, fonts and checksums.

Official program homepage: http://www.radeon2.ru/radedit_eng.html

Contents:

  • RadEdit.exe - Windows GUI version
  • RadEdit.chm - this help file
  • RadClk.exe - DOS command-line version
  • Vendor.IDs - PCI VendorID list

    • This program is written by Alex Yakovlev

    Special thanks to:

  • Vladimir Gerasimov and Oleg for fixing my card
  • Dmitry aka Viller from radeon2.ru.
  • Ichneumon from www.Rage3D.com
  • Maxim Pavlousenko
  • Alexey Monastyrenko
  • Vladimir Poletaev
  • John Hoek
  • Piotr Wilczek
  • all beta testers


Changes history

  Version 1.1:
    25.04.2002:
      * BIOS Reconstruction for Gigabyte AP64DH
      * Refresh rate change

  Version 1.0:
    19.02.2002: some minor changes

  Version 0.9.9d beta:
    14.02.2002:
      * more support for non-ATi (Gigabyte) bioses
     4.02.2002:
      * no more checksums in GUI

  Version 0.9.9c beta:
    27.01.2002:
      * GUI no more loads files with bad checksums
      * 8500 BIOS reconstruction
      * 'None' TVstd always present
      * Vendors bugfix
      * PCIR bugfix
      * Help bugfix

  Version 0.9.9b beta:
    22.01.2002:
      * no more Win32 console version
      * VendorID change
      * CAS1 'Ultra', 2 'Normal', 3 'Slow', no 4
      * 'Enable' unsupported TV stds.
      * some bios restore code, based on 8500

  Version 0.9.9a beta:
    22.01.2002:
      * ViewFonts bugfix
      * 9x16 and 8x14 fonts bugfix
    20.01.2002:
      * View fonts...
      * /n not to fix checksums

  Version 0.9.9 beta:
    19.01.2002:
      * ATi header dump
      * 'ram' pseudo file name in RadClkD
      * /a enables all TV standards
      * PCI device detection and re-init with /i in RadClkD
      * /r BIOS image restore stub for future...
    18.01.2002:
      * Memory timings: SDR/DDR, CAS
      * All TV standards are marked 'supported' when checkbox is on
      * clocks change when SDR/DDR mismatch (for All-in-wonder 8500DV)
    16.01.2002:
      * bugfix: script parts were dumped without /d
      * RadClk shows effective DDR clock: 274.50 (549.00) MHz

  Version 0.9.8 beta:
    10.01.2002:
      * if real clocks not found - it is shown in GUI instead of zeroes
      * max image size changed to 64k
      * min/max clocks set to 50/450
      * scripts dump changed
      * english help kindly edited by Ichneumon from www.Rage3D.com
      * Type2 script detection (looking for Rage128 real clocks...)

  Version 0.9.7d beta:
    09.01.2002:
      * support added for bioses with VendorID != 0x1002
        e.g. 'P/N113-PP-7112-100 PC PARTNER RV100 4MX16 SDR'

  Version 0.9.7c beta:
    08.01.2002:
      * 'List unsupported TV standards' checkbox added

  Version 0.9.7b beta:
    08.01.2002:
      * Some Rage128 support, no script, no clocks :(
      * some help updates

  Version 0.9.7a beta:
    07.01.2002:
      * 9x16 fonts support (info now dumped with /d switch)

  Version 0.9.7 beta:
    07.01.2002:
      * RadEdit lists only supported TV standards
      * RadClk shows run/init time supported TV standards

  Version 0.9.6a beta:
    04.01.2002:
      * TV init combobox
      * CRTon/TVon checkboxes
    30.12.2001:
      * TV standards added: PAL-CN PAL-N

  Version 0.9.6 beta:
    27.12.2001:
      * HtmlHelp added :-)
      * Clock area is dumped with /d switch
    22.12.2001:
      * Default filter both *.rom & *.bin, *.cpi & *.fnt
      * OFN_HIDEREADONLY added to CFileDialog
      * 32k Checksum in GUI

  Version 0.9.5 beta:
    21.12.2001:
      * released @ http://www.radeon2.ru/radedit.html
    18.12.2001:
      * icon & minimize button added
      * 'aka Alex14N' added
    12.12.2001:
      * clock rounding changed
    11.12.2001:
      * chip init script address @ zone2 + 0x46 & zone + 0x52

  Version 0.9.4 beta:
    10.12.2001:
      * check_font modified

  Version 0.9.3 alpha:
    09.12.2001:
      * no 27Mhz div/mul, constant 2.25 Mhz step
      * '.dat' -> '.fnt'
      * .cpi files reader
      * RadClkD - DOS version (32-bit PMode/W)
    06.12.2001:
      * min=75

  Version 0.9.2 alpha:
    03.12.2001:
      * synchronous mode added
      * default extension '.rom'
      * homepage -> www.radeon2.ru. according to contest rules
      * added fonts load/save/check in GUI version :)
      * exception (in winXP) fixed when opening non-bios files
      * no compilation warninigs with /W3 now :)
      * more renaming...
      * possible CRC error fixed
      * UPX exe packing

  Version 0.9.1 alpha:
    02.12.2001:
      * renamed to: RadClk - console, RadEdit - gui
      * first GUI implemented
      * ati_bios class implementation started
      * Warning if ref.clk != 27 or div != 12

  Version 0.9.0 alpha:
    01.12.2001:
      * TV standard detection
    30.11.2001:
      * versioning started
      * 32k checksum update
      * RadClk.exe 'file1' 'file2' mode just to fix checksums
      * Reference, div, min and max clocks detection (???)

  No version:
    28.11.2001:
      * dynamic chip init script[s] detection
    25.11.2001:
      * 'r85clk' - fixed-position R8500 clock change

To do:
 * Refresh rate for DOS/VESA modes
 * Multi-Language; all strings -> .rc


Notes on BIOS structure

File:
0x0000: 0x55 0xAA
0x0002: db bios size in 512-byte pages
0x0003: jmp ...init...
0x0018: offset PCIR
0x001E: 'IBM'
0x0030: " 761295520"
0x0048: offset ATi_header
0x0050: date/time

0x0074/70: dw 0x1002 - VendorID (ATi) ... 0x174B PC PARTNER ?
0x0076/72: dw  - SubProdID

0x0080: title

PCIR:
0x0000: 'PCIR'
0x0004: dw VendorID = 0x1002 (ATi)
0x0006: dw ProductID

ATi_header:
0x0000: db header version

0x000A: offset 'PMI' ?
0x000C: offset Type2 script1
0x000E: offset CRC_zone
0x0010: offset original file name
0x0012: offset Title
0x0014: offset id/name/title2

0x001C: dw 0x1002 - VendorID ... 0x174B PC PARTNER ?
0x001E: dw - SubProductID
0x0020: dw - ProductID

0x0030: offset Clock_zone
0x0032: offset TV_zone
0x003A: '$TVS' - dynamic TV standard support
0x0046: offset Type1 script1
0x004E: offset Type2 script2
0x0054: offset Type1 script2

Clock_zone:
0x0000: db 0x0A / 0x08 - version?
0x0001: db 0x46 / 0x32 - clock zone length
0x0002: db 03, 03 / 02 - ?
0x0004: dw offset ?
0x0006: dw offset ?
0x0008: dw M-CLK
0x000A: dw X-CLK
0x000E: dw reference
0x0010: dw ref. div ?
0x0012: dw min clock ?
0x0016: dw max clock ?

TV_zone:
0x0000: '$TV'
0x0007: db TV init type
0x0009: bit: 01 - CRT on; 02 - TV on;
0x000A: db/bit: Run time supported TV standards
0x000B: db/bit: Init time supported TV standards

CRC_zone:
0x0000: crc1
0x0008: checksum1
0x0020: crc2
0x0028: checksum2


Notes on chip init scripts

Type1:

 0A - 0C XX YY 01:  XX - mem, YY - core clock, base 2.25Mhz (=27Mhz/12?)
 12 - 12 12 ?? ??:  Mem timings?  12/12 for DDR, 22/22 for SDR... 23/23 - 8500DV

 0F, 10, 11 - Mem timings?

Radeon 7500/8500:
 0C - 33 A4 00 04 - Retail
 0C - 33 BC 00 04 - OEM/LE

Type2 (Rage128):

80/60 MHz @ 14.32 Mhz clock:
 Reg0[0130] <- 50
 Reg0[0140] and 00000000 or 13008301
 Reg0[02E8] and 00000000 or 08900262
 Reg0[02EC] and 00000000 or 0F7D7BE8
 Reg0[0B00] and FFFFFFF0 or 00000010

90/90 Mhz @ 29.5 Mhz clock:
 Reg0[0130] <- 60
 Reg0[0140] and 00000000 or 50004300
 Reg0[02E8] and 00000000 or 08900393
 Reg0[02EC] and 00000000 or 173BB9DC
 Reg0[0B00] and FFFFFFF0 or 00000021

103/103 Mhz @ 29.5 Mhz clock:
 Reg0[0130] <- 70
 Reg0[0140] and 00000000 or 70004300
 Reg0[02E8] and 00000000 or 09A0020B
 Reg0[02EC] and 00000000 or 0D4B6A5A
 Reg0[0B00] and FFFFFFF0 or 00000031

118/140 MHz @ 27 Mhz clock:
 Reg0[0130] and FFFFFF00 or 00000054
 Reg0[0140] and 00000000 or C0004300
 Reg0[02E8] and 00000000 or 09A002C7 - mem timigs?
 Reg0[02EC] and 00000000 or 1211908F - ? mem
 Reg0[0B00] and FFFFFFF0 or 00000042


Графическая версия

Load... - загрузить образ биоса

Save... - записать измененный образ биоса в файл

Exit - выйти из программы

Help - вызвать эту справку

Двигая ползунки вы меняете частоты ядра/памяти

Synchronize clocks меняет режим синхронного/асинхронного изменения частот.

Внимание! Карты на чипах R100/RV100 рассчитаны только на синхронные частоты!

Load 8x8 font... - загрузить шрифты 8x8.

Load 8x16 font... - загрузить шрифты 8x16.

RAM... - попробовать восстановить биос по образу из памяти.


Текстовая (консольная) версия

Описание параметров:

RadClk [/d] [/l|/s] bios.rom [частота_чипа частота_памяти] [newbios.rom]
  • RadClk - имя программы
  • /d - выводит параметры инициализации чипа
  • /l - загружает шрифты из файлов font8x8.fnt и font8x16.fnt в биос
  • /s - записывает шрифты из биоса в файлы font8x8.fnt и font8x16.fnt
  • bios.rom - имя файла с образом биоса
  • частота_чипа - в мегагерцах
  • частота_памяти - в мегагерцах
  • newbios.rom - имя файла для записи модифицированного образа биоса, если не указано то изменения записываются в тот же файл

Примеры:

RadClk.exe bios.rom - выводит информацию о биосе из файла bios.rom. Пример вывода программы:

ATi Radeon series BIOS clocking utility, Version 0.9.9 beta
Written by Alex Yakovlev aka Alex14N, http://www.radeon2.ru/radedit.html

Image size: 0xC000 (49152 bytes)

Date: 2001/07/31 11:35
ID 1: P/N113-PP-7112-100 PC PARTNER RV100 4MX16 SDR
ID 2: BK5.0.0 VR000.000.006.000.004.001.001.000 yipprt4m.500 v611
ID 3: R100AGP SGS1UN
ID 4: 0x174B 0x5159 0x7112

Reference clock:  27.00 Mhz
X-CLK / M-CLK:   143.00 / 143.00 MHz

Core clocking:   141.75 MHz  (63*2.25)
Memory clocking: 141.75 MHz  (63*2.25)
Effective mem:   141.75 MHz  (SDR; 64 bits bus)

Built-in initialization TV standard: NTSC
Run time TVs: NTSC, PAL
Inittime TVs: NTSC, PAL

CRC:  CDEC660B,  file1: CDEC660B  file2: CDEC660B
Checksum: 9100,  file1:     9100  file2:     9100

RadClk.exe bios.rom 268 266 - устанавливает частоты биоса bios.rom 268 МГц ядра и 266 МГц памяти

RadClk.exe bios.rom fixed.rom - загружает файл bios.rom, выводит его параметры, и записывает в файл fixed.rom, исправляя при необходимости контрольные суммы

RadClk.exe /d bios.rom > script.txt - выводит параметры биоса и программу инициализации чипа в файл script.txt


ДОС-версия

RadClk поддерживает всю функциональность консольной Win32 версии, плюс:

указание 'ram' в качестве имени файла позволяет считать или записать образ биоса из/в Shadow ROM.

Внимание! Ни в коем случае не следует пробовать прошить образ биоса снятый из памяти, а не из флэша!

параметр /r в будущем, возможно, позволит корректно восстановить образ биоса из памяти.

параметр /i позволяет проинициализировать записываемый в Shadow ROM образ биоса

параметр /a включает все стандарты ТВ

параметр /n не исправляет контрольные суммы

Примеры:

RadClk ram - выводит на экран параметры биоса в памяти

RadClk /a ram - включает все ТВ-стандарты в памяти (Shadow ROM)

RadClk /i bios.rom ram - загружает и инициализирует образ биоса из файла bios.rom в память (Shadow ROM)


Где взять образ биоса для редактирования

Самый простой, и, наверное, правильный способ - из вашей же видеокарты. Для этого в программах прошивки нужно выбрать опцию записи образа биоса в файл, например:

flashrom -s 0 my_bios.rom

Также можно взять образ биоса совместимой видеокарты из раздела Downloads сайта radeon2.ru.

Обычно это стоит делать для изменения видео стандарта PAL/NTSC, или для большего разгона карты - например, Radeon 8500 LE, при прошивке биоса от Retail карты, может гнаться на лишних 2-5 мегагерц, или даже больше.


Чем прошить биос

Для прошивки биоса существуют специальные программы, которые можно скачать из раздела Downloads сайта radeon2.ru.

Перед прошивкой неродного биоса настоятельно рекомендуется:

  1. Сохранить образ старого биоса,
  2. Проверить работоспособность карты на прошиваемых частотах, выставив эти частоты программой типа PowerStrip, и убедиться в отсутствии глюков, например тестом 3Dmark2001 (особенно чувствительны к переразгону Game2 и Game3 в настройках High и Vertex Shader Test)
  3. При использовании PowerStrip отключите автоматическую загрузку настоек (установив Performance default), или даже снесите его ini-файл, в противном случае при следующей загрузке он восстановит настройки карты до прошивки и вы не увидите изменений.
  4. Проверить параметры и контрольные суммы нового биоса в редакторе или утилитой BiosInfo
  5. При прошивке загрузиться в чистый DOS (без himem.sys и прочего)
  6. Проверить работоспособность нового биоса утилитой RamBios,
  7. Иметь под рукой PCI или ISA видеокарту для восстановления биоса.


Шрифты

Редактор биосов дает возможность изменить шрифты в образе биоса для текстовых режимов, что позволяет, например, руссифицировать биос и во-первых, обходиться без дополнительных программ-руссификаторов, съэкономить несколько килобайт памяти в DOS-е, и иметь возможность читать русские сообщения об ошибках, возникающих до загрузки руссификатора.

Существует 4 размера шрифтов для DOS-режимов: 8x8, 8x14, 8x16 и 9x16, но в биосах карт серии Radeon шрифты 8x14 отсутствуют, о чем написано на сайте ATi, откуда при необходимости можно скачать программу для их поддержки. Символы шрифт 9x16 хранятся не все, а только отличающиеся от 8x16.

Консольный вариант редактора работает только с файлами, содержащими единственный шрифт. В этих файлах последовательно хранятся побитовые изображения всех 256 символов, при этом символы 8x8 занимают 8 байт, а 8x16 - 16, и размеры файлов получаются 2048 и 4096 байт соответственно.

Мне неизвестно, чем можно редактировать такие файлы, хотя в свое время для DOS-а существовало несколько редакторов растровых шрифтов, и не исключено что редактор появится в одной из будущих версий этой программы.

Пока наилучший способ руссификации - взять шрифты из уже руссифицированного биоса из раздела Downloads сайта radeon2.ru. Команда:

RadClk.exe /s ddr_rus.rom

записывает шрифты из образа биоса ddr_rus.rom и записывает их в файлы font8x8.fnt и font8x16.fnt. Затем командой:

RadClk.exe /l my_bios.rom

можно загрузить эти шрифты в образ биоса my_bios.rom.

Графический вариант редактора позволяет также читать файлы со шрифтами формата cpi. Для Windows 95/98/ME он находится в каталоге:

C:\Windows\Command\Ega3.cpi

а для Windows NT/2000/XP:

C:\Windows\System32\Ega.cpi

шрифты 8x8 и 8x16 загружаются независимо, и при загрузке предлагается выбрать кодовую страницу нужного шрифта. Для русской кодировки это 866.

Таким образом, алгоритм руссификации биоса таков:

  1. Запускаем редактор биосов RadEdit.exe
  2. Нажимаем кнопку Load... и выбираем нужный файл с образом биоса
  3. Нажимаем кнопку Load 8x8 font...
  4. Выбираем файл ega3.cpi или ega.cpi в зависимости от варианта Windows
  5. Выбираем кодовую страницу 866 и нажимаем кнопку OK
  6. Нажимаем кнопку Load 8x16 font...
  7. Аналогично п.5-6 выбираем cpi-файл, кодовую страницу, и нажимаем OK
  8. Нажимаем кнопку Save... и записываем новый образ в файл.


Контрольные суммы

В образах биосов карт серии Radeon используется 4 варианта контрольных сумм:

1. CRC32

32-битное число, вычисляемое следующим образом: для каждого байта образа биоса предыдущее значение CRC32 циклически сдвигается на 1 бит влево, после XOR-ится (побитовое исключающее или) со значением байта образа. Полученное значение должно совпадать со значением, хранимым в образе биоса (в 2 копиях).

2. Checksum

16-битная сумма всех байт биоса. Младший байт суммы должен получится нулевым, а старший должен совпадать со значением, хранимым в образе биоса (в 2 копиях).

3. 64k Checksum

16-битная сумма всех байт биоса, дополненных до 64 килобайт значением 0xFF, младший байт суммы должен получится нулевым, что гарантируется если корректна контрольная сумма недополненного биоса.

4. 32k Checksum

16-битная сумма первых 32 килобайт биоса, младший байт суммы должен получится нулевым.

В новых биосах обычно не используется, но редактор ее исправляет "на всякий случай".

Поэтому, а также потому, что алгоритмы исправления контрольных сумм могут отличатся, может происходить такая странность, что если настоящий родной биос от ATi загрузить в редактор, и, ничего не изменяя, записать в файл, то полученный файл может отличаться на несколько байт от оригинала.

Контрольные суммы пересчитываются автоматически при записи файла, поэтому значения контрольных сумм в редакторе имеют чисто информативный характер, в основном чтобы обратить внимание при загрузке биоса, что если контрольные суммы не совпадают, то возможно, биос был снят некорректно, и, возможно, является нерабочим; или же биос кем-то изменен, что также может привести к его неработоспособности.

Обычный способ неправильного снятия биоса - запись его не из флэша программой для прошивки, а из образа памяти после загрузки. Дело в том, что в современных компьютерах при загрузке содержимое биоса копируется в область основной памяти (Shadow ROM), и модифицируется во время инициализации, при этом снятые таким образом биосы не подлежат прошивке и не работают.


Выход на ТВ

PAL - европейский стандарт, 50 Гц.

NTSC - американский стандарт, 60 Гц.

Если вам повезло :-) и ваш биос поддерживает несколько ТВ-стандартов, то вы можете изменить стандарт в поле "TV initialization standard".

Внимание! В этой версии редактора добавлена возможность выбора неподдерживаемого стандарта (если включить "List unsupported standards"), но данная функция не тестировалась и может привести к полной неработоспособности видеокарты.


Производители

VendorID

Модель видеокарты задается тремя параметрами:

VendorID - код фирмы-разработчика (0x1002 для ATi)

ProductID - код продукта

SubProductID - под-код продукта

VendorID задается в двух местах - в таблице PCIR и в заголовке биоса, причем эти два значения могут не совпадать. Таким образом, может быть три типа биосов:

  1. карты, у которых оба значения 0x1002 (ATi)
  2. карты, у которых 0x1002 в PCIR и другой код в заголовке биоса (обычно это карты, сделанные ATi для другой фирмы)
  3. карты, у которых оба кода отличны от 0x1002 (это могут быть карты, сделанные на чипах ATi, но я таких еще не видел)

Значение в PCIR настоятельно рекомендуется не трогать, поскольку есть риск запороть карту так, что нельзя будет даже прошить старый биос, а значение в заголовке биоса (насколько я понимаю, оно имеет чисто информативный характер) можно менять в редакторе.


О программе

Данная программа предоставляется КАК-ЕСТЬ. Ни автор, ни сайт radeon2.ru, не несут никакой ответственности за возможный ущерб, причиненный использованием данной программы.

RadEdit - редактор образов биосов видеокарт серии ATi Radeon, на данный момент позволяет изменять частоты ядра и памяти, шрифты и контрольные суммы биосов.

Официальная веб-страница программы: http://www.radeon2.ru/radedit.html

Состав:

  • RadEdit.exe - графический вариант
  • RadEdit.chm - эта справка
  • RadClk.exe - текстовый вариант для DOS
  • Vendor.IDs - список кодов производителей

    • Текстовый вариант для ДОСа работает и под виндами, но у него есть проблемы с длинными именами.

    Автор программы - Алекс (Александр) Яковлев

    Особая благодарность:

  • Владимиру Герасимову и Олегу за починку моей видеокарты
  • Дмитрию aka Viller с сайта radeon2.ru
  • Ichneumon from www.Rage3D.com
  • Максиму Павлусенко
  • Алексею Монастыренко
  • Владимиру Полетаеву
  • John Hoek
  • Piotr Wilczek
  • всем бета-тестерам

    • версия 1.1:

  • изменение частоты обновления экрана
  • реконструкция биоса Gigabyte AP64DH

    • версия 1.0:

  • поддержка биосов с не-ATi-шными VendorID в PCIR (Gigabyte)
  • контрольные суммы убраны совсем

    • версия 0.9.9c:

  • восстановление биоса 8500 из образа в памяти
  • графическая версия больше не загружает файлов с неверными контрольными суммами
  • всегда есть ТВ-стандарт 'None'
  • исправлено несколько ошибок

    • версия 0.9.9b:

  • консольной Win32 версии больше не будет
  • возможность изменения производителя (VendorID)
  • исправление "Enable unsupported TV standards"

    • версия 0.9.9a:

  • добавлен просмотр шрифтов
  • исправлен глюк со шрифтом 9x16
  • /n не трогает контрольных сумм

    • версия 0.9.9:

  • добавлена поддержка таймингов памяти (SDR/DDR, CAS)
  • при включении "List unsupported TV standards" все стандарты помечаются как поддерживаемые. в итоге дрова дают выбор системы NTSC и PAL (и их вариаций), только требуют перезагрузки
  • добавлена возможность чтения образа биоса из памяти в ДОСе (Внимание! ни в коем случае не следует пробовать прошивать образ биоса, взятый из памяти!) и пробовать загружать образ биоса в память как аналог RamBios
  • включить все стандарты ТВ теперь можно и из консольной версии

    • версия 0.9.8:

  • отредактирована английская справка
  • добавлен разбор еще одного типа скриптов (в поисках частот в биосах Rage128)
  • изменен формат вывода скриптов
  • добавлена поддержка биосов с неродным VendorID

    • версия 0.9.7 (распростанялась только среди бета-тестеров):

  • добавлена (но не проверена) возможность выбора ТВ-стандарта, не поддерживаемого биосом
  • добавлена возможность изменения ТВ-стандарта (пока только если эта функция поддерживается биосом) и активного выхода (монитор/ТВ)
  • добавлена возможность просмотра биосов Rage128, но пока не реализовано правильное изменение частот
  • добавлена поддержка шрифтов 9x16

    • версия 0.9.6:

  • добавлена справка (help)
  • показывается 32k checksum

    • версия 0.9.5:

  • первый релиз


ЧаВО

Где я могу больше узнать о биосах?

на сайте Radeon2.ru

Когда можно будет менять дату и заголовок биоса?

Скорее всего - никогда. На мой взгляд, это создаст ненужную путаницу, и никакой пользы не несет. С другой стороны сделать это несложно, и если меня кто убедит в нужности этого - сделаю.

Когда будет работать CRTon/TVon?

Работа над этим ведется, ждите, надежда еще жива :) Можете попробовать выбрать 'None' в качестве ТВ-стандарта.

Когда будет поддержка Rage128 и FireGL2/3/4?

Карточки Rage128 у меня нет, поэтому разобраться где же именно и как нужно ставить частоту я пока не смог, кое-какие предположения есть вот здесь. Если кто может помочь, а еще лучше - подробно описать как же менять частоты Rage - буду очень рад. Пока можно только поменять шрифты :)

FireGL, скорее всего, никогда - формат их биосов имеет очень мало общего с картами серий Radeon и Rage.

Что будет, если я поставлю CAS1?

На 8500 этого лучше не делать - никакого изменения в скорости замечено не было, а глюки бывают. На 7500 и ниже это может ускорить работу с памятью и скорость в играх на 10-30% (но при этом память сильно греется), а может ничего не заработать, никаких гарантий нет. В любом случае, проверьтесь сначала с RamBios, и имейте под рукой PCI-карту на случай восстановления.

Чем я могу помочь?

Присылайте отзывы, комментарии, пожелания, результаты тестов, описания ошибок мне на е-мейл. Особо крупные файлы лучше вот сюда.

А будет ли работать с FireGL8800, RV250, R300, ... ?

Жду, не дождусь биосов, присылайте скорее!

Чем ты сам исследуешь и редактируешь биосы?

Far, Hiew (Hacker's View), IDA (Interactive Disassembler)

Какая видеокарта у тебя?

Radeon 8500 LE